Inicio de mvnForum Bienvenido Guest   | Iniciar sesión
  Búsqueda  
  Indice  | Temas Recientes  | Quién Está en Línea  | Lista de Usuarios  | Nuevo Usuario  | Búsqueda  | Ayuda  | RSS feeds


Ir a »
Estado del tema: Normal
Total de mensajes en este tema: 2
[Añadir a Mis Favoritos] [Añadir un aviso a este tema] [Publicar nuevo tema]
Autor
Tema Anterior Este tema ha sido visto 5503 veces y tiene 1 respuesta Tema Siguiente
Femenino lcouso
Advanced Member



Ingresó: 24-jul-2009
Mensajes: 100
Estado: Desconectados

Usando el collector="byQuery" Responder a este mensaje
Responder citando

Buenos días chic@s,
me parece muy buena opción la que propone el collector="byQuery" para listar solo aquellos contenidos que quieras, sin tener que hacer bucles y bucles anidados, llenos de comprobaciones.

Aún así, no se muy bien como se trabaja con él. Por lo que yo he podido averiguar, tira del indice "Solr Offline" o "Solr Online".

En la query, puedes hacer referencia a los campos ya mapeados (/solr/conf/schema.xml) o crear alguno nuevo.

<field name="tipoform" type="boolean" indexed="true" stored="true" multiValued="true"/>


En el XSD tenemos que asignar el tipo creado al campo que queremos mapear.


<xsd:annotation>
<xsd:appinfo>
[...]
<searchsettings>
<searchsetting element="Formulario" searchcontent="true">
<solrfield targetfield="Formulario" sourcefield="tipoform" />
</searchsetting>
<searchsettings>
[...]
</xsd:appinfo>
</xsd:annotation>



Una vez montado todo esto, reiniciado el servidor, e incluso reconstruido el indice Solr... hago pruebas con la query, desde la url:


http://[server_name]/opencms/opencms/handleSolrSelect?q=parent-folders:/sites/site_name/es/conductores/&fl=tipoform


y no consigo ver este campo en los resultados, ni filtar por el ni nada.

¿Que estoy haciendo mal? ¿Me falta algo? ¿Por que no sale mi nuevo campo en el mapeo?
[22-sep-2016 10:43:07] Mostrar la Versión Imprimible        Send Private Message [Enlace] Reportar mensaje ofensivo: por favor inicie sesión primero  Ir al inicio 
Femenino lcouso
Advanced Member



Ingresó: 24-jul-2009
Mensajes: 100
Estado: Desconectados

Re: Usando el collector="byQuery" Responder a este mensaje
Responder citando

Puede ser por que mis XSD estén anidados????
[22-sep-2016 10:45:43] Mostrar la Versión Imprimible        Send Private Message [Enlace] Reportar mensaje ofensivo: por favor inicie sesión primero  Ir al inicio 
[Versión imprimible] [Publicar nuevo tema]