Inicio de mvnForum Bienvenido Guest   | Iniciar sesión
  Búsqueda  
  Indice  | Temas Recientes  | Quién Está en Línea  | Lista de Usuarios  | Nuevo Usuario  | Búsqueda  | Ayuda  | RSS feeds


Ir a »
Estado del tema: Normal
Total de mensajes en este tema: 3
[Añadir a Mis Favoritos] [Añadir un aviso a este tema] [Publicar nuevo tema]
Autor
Tema Anterior Este tema ha sido visto 5513 veces y tiene 2 respuestas Tema Siguiente
Femenino beatrizprados3
Member



Ingresó: 26-oct-2012
Mensajes: 60
Estado: Desconectados

Buscador Opencms Responder a este mensaje
Responder citando

Hola,

he configurado el buscador en mi portal, basado en Lucene porque Solr no me funciona. ¿tenéis conocimiento de agujeros de seguridad que tenga este buscador? Por ejemplo, sql inyection...

Gracias
[17-dic-2012 13:22:03] Mostrar la Versión Imprimible        Send Private Message [Enlace] Reportar mensaje ofensivo: por favor inicie sesión primero  Ir al inicio 
Masculino sergio
Administrador
Avatar del Miembro

España
Ingresó: 27-sep-2006
Mensajes: 2470
Estado: Desconectados
Re: Buscador Opencms Responder a este mensaje
Responder citando

En principio no, pero para evitarlo antes de enviar la consulta a lucene verifica que no venga ningún código raro ni nada.

De todas formas, estás con OpenCms 8.5? Solr te debería funcionar sin problema, que es lo que le pasa?
----------------------------------------
---------------------------------------------------
Sergio Rapos Vargas.
Administrador de OpenCmsHispano.
sergio.raposo@opencmshispano.es
[20-dic-2012 8:04:34] Mostrar la Versión Imprimible        Send Private Message [Enlace] Reportar mensaje ofensivo: por favor inicie sesión primero  Ir al inicio 
Femenino beatrizprados3
Member



Ingresó: 26-oct-2012
Mensajes: 60
Estado: Desconectados

Re: Buscador Opencms Responder a este mensaje
Responder citando

Cuando intento crear un índice solr con la siguiente configuración:
Configuración de campos_: solr_fields

Me da error:

org.opencms.search.solr.CmsSolrField cannot be cast to org.opencms.search.fields.CmsSearchField

También me fallan los índices que vienen por defecto al indexar automáticamente
[26-dic-2012 8:36:18] Mostrar la Versión Imprimible        Send Private Message [Enlace] Reportar mensaje ofensivo: por favor inicie sesión primero  Ir al inicio 
[Versión imprimible] [Publicar nuevo tema]