Inicio de mvnForum

Imprimir en 28-nov-2022 5:56:39
Mensajes: 11   Páginas: 2   [ 1 2 | Siguiente ]
Ver todos los mensajes del tema en una sola página
Publicado por tecjh en 21-nov-2007 9:23:16
Problemas para ver la pagina web creada
Hola a todos,

Tengo instalado Apache 2.2.4 + MySQL 5.0.45 + Tomcat 5.5.25 + + OpenCMS 7.0.1 y he migrado una web a opencms pero tengo problemas para ver las paginas del proyecto que he creado. Al meter la url de la pagina web me sale el portal de opencms para logearme y administrar la web creada. Necesito que al poner la direccion web me salga la paguina de inicio que he creado. He publicado todas las carpetas y plantillas.

Gracias, un saludo

Publicado por Alejandro en 21-nov-2007 10:38:01
Re: Problemas para ver la pagina web creada
¿qué url es la que pones?
----------------------------------------
---------------------------------------------------
Alejandro Alves Calderón
Administrador de OpenCmsHispano.
alejandro.alves@opencmshispano.com
www.alejandroalves.com

Publicado por tecjh en 21-nov-2007 12:04:34
Re: Problemas para ver la pagina web creada
la url es www.teccon.es

Esa url te lleva a la pagina de Teccon anterior no a la migracion que he hecho con opencms.
En la pagina que he hecho tengo mi microsite con la carpeta pages y sus correspondientes paginas.

Gracias

Publicado por Alejandro en 21-nov-2007 12:05:24
Re: Problemas para ver la pagina web creada
Y la configuarción del apache está bien hecha?
----------------------------------------
---------------------------------------------------
Alejandro Alves Calderón
Administrador de OpenCmsHispano.
alejandro.alves@opencmshispano.com
www.alejandroalves.com

Publicado por tecjh en 21-nov-2007 12:24:22
Re: Problemas para ver la pagina web creada
Esta es basicamente la conf q tengo:

Editamos el archivo de configuración de Apache (httpd.conf en la carpeta conf) para que
se cargue el módulo al iniciar el servidor. En la sección LoadModules añadimos:

LoadModule alias_module modules/mod_alias.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_http_module modules/mod_proxy_http.so

# Virtual hosts
Include conf/extra/httpd-vhosts.conf

En el DocumentRoot del tomcat tendremos la siguiente estructura de ficheros webapps/ROOT/WEB-INF/config/
opencms-importexport.xml, lo editamos y en el "<rendersettings>" suprimiremos el literal "${SERVLET_NAME}"
y donde pone "<exporturl>http://127.0.0.1:8080${CONTEXT_NAME}/handle404</exporturl>", es decir, dos lineas
por debajo lo modificamos a "<exporturl>http://127.0.0.1:8081${CONTEXT_NAME}/handle404</exporturl>". Se
quedara algo como esto:

<rendersettings>
<rfs-prefix>${CONTEXT_NAME}/export</rfs-prefix>
<vfs-prefix>${CONTEXT_NAME}</vfs-prefix>
<userelativelinks>false</userelativelinks>
<exporturl>http://127.0.0.1:8081${CONTEXT_NAME}/handle404</exporturl>
... (AQUI PUEDE VENIR LO QUE SEA NO TIENE QUE HABER 3 PUNTOS)
</rendersettings>

En el DocumentRoot del tomcat tendremos la siguiente estructura de ficheros webapps/ROOT/WEB-INF/config/
opencms-system.xml, lo editamos y en el "<sites>" modificamos los valores "${DOMAIN_NAME}" para que
aparezca el nombre del dominio que nos interese. Tendra que ser algo asi.

<sites>
<workplace-server>http://www.midominio.com<workplace-server>
<default-uri>/sites/default/</default-uri>
<site server="http://www.midominio.com" uri="/sites/default/"/>
</sites>

En el DocumentRoot del tomcat tendremos la siguiente estructura de ficheros /conf/ donde tendremos el
fichero server.xml el cual modificaremos para que sea igual al siguiente texto.

<Server port="8005" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">
<!-- Define a connector for the "public visible" server name -->
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8081" minProcessors="5" maxProcessors="75"
proxyName="www.midominio.com" proxyPort="80" useBodyEncodingForURI="true" enableLookups="true" redirectPort="8443"
acceptCount="100" debug="0" connectionTimeout="20000" useURIValidationHack="false" disableUploadTimeout="true" />

<Engine name="Standalone" defaultHost="localhost" debug="0">
<Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="true">
<!-- You can change "unpackWARs" and "autoDeploy" to false after the installation is finished -->
<Logger className="org.apache.catalina.logger.FileLogger" directory="logs" prefix="localhost_log." suffix=".txt"
timestamp="true"/>
</Host>
</Engine>
</Service>
</Server>

En el DocumentRoot del apache tendremos la siguiente estructura de ficheros /conf/ donde tendremos el
fichero httpd.conf en el cual tendremos que tener lo siguiente descomentado:

LoadModule alias_module modules/mod_alias.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_http_module modules/mod_proxy_http.so

# Virtual hosts
Include conf/extra/httpd-vhosts.conf

Y en el DocumentRoot del apache tendremos la siguiente estructura de ficheros /conf/extra/ donde tendremos el
fichero httpd-vhosts.conf, en el cual tendremos que introducir lo siguiente.

<VirtualHost *:80>
<Directory "C:/www/Tomcat5.5/webapps/ROOT/">
Order allow,deny
Allow from all
</Directory>
ServerName midominio.com
ServerAdmin uatienzar@teccon.es
DocumentRoot "C:/www/Tomcat5.5/webapps/ROOT/"
ErrorLog logs/error.log

# Log only non-redirect requests in "normal" log file
SetEnvIf Request_URI "\/opencms\/*" redirect
CustomLog logs/localhost-access.log common env=!redirect
ProxyPass /opencms/ !
RedirectPermanent /opencms/ http://www.midominio.com/
ProxyPass /resources/ http://localhost:8081/resources/
ProxyPassReverse /resources/ http://localhost:8081/resources/
ProxyPass /export/ http://localhost:8081/export/
ProxyPassReverse /export/ http://localhost:8081/export/
ProxyPass / http://localhost:8081/opencms/
ProxyPassReverse / http://localhost:8081/opencms/
</VirtualHost>

Publicado por Alejandro en 21-nov-2007 16:04:55
Re: Problemas para ver la pagina web creada
A mi me huele que tu problema está en el apache, pero yo nunca lo he configurado. Lo siento.
----------------------------------------
---------------------------------------------------
Alejandro Alves Calderón
Administrador de OpenCmsHispano.
alejandro.alves@opencmshispano.com
www.alejandroalves.com

Publicado por sergio en 21-nov-2007 16:31:37
Re: Problemas para ver la pagina web creada
A mi me huele que tb ....hay algo que no apunta bien a la ruta.

La web te carga correctamente cuando apuntas al sitio directamente??
----------------------------------------
---------------------------------------------------
Sergio Rapos Vargas.
Administrador de OpenCmsHispano.
sergio.raposo@opencmshispano.es

Publicado por tecjh en 21-nov-2007 16:47:27
Re: Problemas para ver la pagina web creada
Cuando escribo toda la ruta hasta la pagina de inicio me carga la pagina pero no todos los estilos. Pongo esta ruta:
http://www.teccon.es/Teccon/pages/Inicio.html

Sabeis donde puedo consegir informacon sobre este problema?

Gracias

Publicado por Alejandro en 21-nov-2007 16:50:27
Re: Problemas para ver la pagina web creada
Tienes todos los recurss bien publicados?
----------------------------------------
---------------------------------------------------
Alejandro Alves Calderón
Administrador de OpenCmsHispano.
alejandro.alves@opencmshispano.com
www.alejandroalves.com

Publicado por tecjh en 21-nov-2007 17:12:29
Re: Problemas para ver la pagina web creada
creo q si, publique todo lo que tenia, boton dcho-publicar

Mensajes: 11   Páginas: 2   [ 1 2 | Siguiente ]